четверг, 18 ноября 2010 г.

То, о чем так много просили. Colorer 1.0.3

Дошли таки руки до новой версии Colorer. Как там , "То, о чем так давно говорили большевики" свершилось. Появилась возможность указывать пути до своих прототипов и стилей раскраски, не задействуя при этом базовый набор. А так же настраивать каждый тип, не правя базовый proto.hrc . Т.е. ваши настройки всегда с вами, в независимости от обновлений базового набора.

Ну а теперь по порядку.

В начале вышел Colorer 1.0.2.14 
Изменения
  1. косметика диалога настроек
    а. описание причины не включения TrueMod
    б. при вызове диалога из "Options -> Plugins configuration " checkbox для включения/отключения TrueMod всегда активен. Предполагается, что системные настройки можно настраивать всегда, плюс ограничение в возможности определения truemod не из редактора.
  2. падение плагина если не найден catalog.xml
  3. возможные падения из-за 1.0.2.10 пункт 2.

Обновления схем
  • batch : метки и комментарии(::) могут начинаться не с первого символа; символ ^ является экранирующим;
  • esc : добавлен атрибут "overload"
Ну а затем  и Colorer 1.0.3
Изменения
  1. Исправлено отображение неверного количества схем в меню выбора схем раскраски
  2. Исправлено раскраска текста только после нажатия клавиши при переходе в открытый файл после перезагрузки базы
  3. Добавлена возможность указания файла со списком пользовательских схем (аналог proto.hrc)
  4. Добавлена возможность указания файла со список пользовательских стилей раскраски (аналог catalog-console.xml)
  5. Добавлен диалог настройки параметров схем. Настройки хранятся в реестре.
  6. Схемы и стили раскраски (базы) перенесены в подпапку base папки плагина. Поиск базы осуществляется только в этой папке либо по пути, заданному в параметрах.

По настройке нововведений написал такую вот инструкцию на форуме Far. По уму уже пора FAQ заводить, но время, время...
P.S. есть уже маленькая бага - для цветовых стилей в своем файле не поддерживаются относительные пути. Точнее они работают относительно catalog.xml.

1 комментарий:

  1. Спасибо, установил на фар последней сборки (2.0.1807 x64), все заработало!

    ОтветитьУдалить